Seneste forumindlæg
Køb / Salg
 * Uofficiel Black/White liste V2
Login / opret bruger

Forum \ Internet \ Internetudbydere

Kviknet IPv6 ?

Af Ny på siden lalandia | 18-11-2021 16:14 | 984 visninger | 20 svar, hop til seneste
Nogen kviknet brugere der har haft held med at få IPv6 fra Kviknet? https://support.kviknet.dk[...] Har forsøgt mange ting, men uanset virker jeg ikke til at få meget svar på DHCPv6 https://pastebin.com[...] Bruger openwrt. Har læst i odhcp6c koden https://github.com[...] https://github.com[...] Og IA_NA og IA_PD virker til at være ret standard og blive triggered af reqaddress='try' eller "Request IPv6-address" (luci web admin > Network > Interfaces > WAN6 > General Settings) Mht. IAID=1 ser det ud til det er så enkelt som at definere 48:1 i reqprefix "Request IPv6-prefix of length" (luci web admin > Network > Interfaces > WAN6 > General Settings) https://forum.openwrt.org[...] Har prøvet begge dele. Både 48:1, 48 og Automatic, bare intet svar fra DHCPv6 på kviknet.
--
#1
VirtualFido
Ny på siden
18-11-2021 16:53

Rapporter til Admin
Jeg kører selv IPv6 hos Kviknet på OPNsense (via EWII fibernet). Det første år var der ingen problemer, men siden starten af oktober i år har det været problematisk med IPv6. Jeg fandt eksempel på config her: https://www.version2.dk[...] Mit problem er, at min router ikke længere selv kan kontakte omverdenen over IPv6, samtidigt med at klienter bag routeren godt kan. Har en support sag kørende hos dem, der har været åben siden starten af oktober. Ingen løsning endnu og seneste svar fra supporten var for 15 dage siden :-(.
--
#2
CyberOpz
Ultra Supporter
18-11-2021 17:46

Rapporter til Admin
Jeg har nøjagtig samme problem som #2. Klienterne får fint IPv6. Routeren assignet IPv6 adresse, men der kan ikke sendes noget over gatewayen...
--
#3
mr doc22
Semi Supporter
18-11-2021 19:16

Rapporter til Admin
#2 Er du sikker på at det er en public ipv6 addresse routeren får? (I ipv6 har enheder en statisk ivp6 addresse udover den ipv6 adresse der er opsat)
--
Ryzen 5 5600X,ASUS TUF GAMING B550 PLUS,G.skill 3600 MHz AUTO C16-16-16-36 4x8GB,AOC G2590FX,Corsair RM850,Sapphire RX 5600 XT 6GB,1 TB NVMe ADATA
--
Sidst redigeret 18-11-2021 19:17
#4
lalandia
Ny på siden
18-11-2021 19:31

Rapporter til Admin
Sjovt, så må det jo virke - også i Nordjylland. Havde overvejet at teste med en anden wide-dhcpv6 klient, men udfra odhcp koden ser det jo ud til at være sådan som de vil have det.
--
#5
VirtualFido
Ny på siden
18-11-2021 19:33

Rapporter til Admin
#3 Det er noget som tidligere har virket i over 1 år, hvor det stoppede med at virke i starten af oktober. Routeren har følgende adresser på WAN interface: - 2a06:4000:32::xxxx/128 (Kviknet range) - 2a06:4000:32:0:xxxx:xxxx:xxxx:xxxx/64 (Kviknet range, indeholder MAC adresse) - 2a06:4003:xxxx::/48 (Delegated prefix, min range hos Kviknet) - fe80::xxxx:xxxx:xxxx:xxxx/64 (Link local, indeholder MAC adresse) Der kan ikke pinges ud fra nogen af adresserne. Det virkede med ping før oktober. Support skrev i slutningen af oktober: "Vi kigger ind i en fast IPv6 DHCP / DNS løsning, så vi fremadrettet kan styre det for den enkelte kunde. Vi kigger også på at øge MTU over hele linjen" Om deres ændringer har medvirket at min opsætning ikke længere er korrekt, det ved jeg ikke. Men hvis det er tilfældet, så håber jeg at de vil opdatere deres FAQ, så man kan bruge IPv6 uden at have deres router.
--
Sidst redigeret 18-11-2021 19:36
#6
stallemanden
HOL Moderator
18-11-2021 20:01

Rapporter til Admin
Det er lidt spøjst. Til info, kan jeg oplyse jer #0, #1 og #2, at i poster alle fra en IPV6 ip her på siden.
--
https://onsdagssnegl.dk[...] "Held er noget, der indtræffer, når grundige forberedelser mødes med gunstig lejlighed"
#7
CyberOpz
Ultra Supporter
18-11-2021 20:08

Rapporter til Admin
#5 - Helt samme oplevelse jeg havde. Men du kan pinge den gateway adresse du har fået tildelt. Det er en link-local adresse. #6 - Er skiftet til Hiper. IPv6 virker her, men netværk og båndbredde er markant dårligere. Kunne dog være interessant om du kunne konstatere om #0 kommer fra et Kviknet prefix?
--
Sidst redigeret 18-11-2021 20:09
#8
stallemanden
HOL Moderator
18-11-2021 20:18

Rapporter til Admin
#7 Det slog mig slet ikke at tjekke det. Men #0 gør ikke. #1 kommer fra Kviknet OgG du kommer fra en IPv4 i #7, og IPv6 i #2
--
https://onsdagssnegl.dk[...] "Held er noget, der indtræffer, når grundige forberedelser mødes med gunstig lejlighed"
#9
VirtualFido
Ny på siden
18-11-2021 20:21

Rapporter til Admin
#6 IPv6 virker fint for klienter bag routeren. Bare ikke fra selve routeren.
--
#10
lalandia
Ny på siden
18-11-2021 20:35

Rapporter til Admin
Virkelig mærkeligt jeg bare intet ser med tcpdump. Jeg forstår ikke :( Hvis nogen skulle hænde at få en openwrt (med default klient odhcp6c) på kviknet ipv6, så ping mig lige.. vil forsøge med en anden klient snart.
--
Sidst redigeret 18-11-2021 20:37
#11
CyberOpz
Ultra Supporter
18-11-2021 20:44

Rapporter til Admin
#8 hehe - Powersaving F*cker med IPv6 nogle gange... Nu burde den være der igen :D
--
#12
lalandia
Ny på siden
19-11-2021 12:30

Rapporter til Admin
01:40:09.386398 IP6 (flowlabel 0xcc88e, hlim 1, next-header UDP (17) payload length: 139) fe80::3e37:86ff:fe2a:d198.546 > ff02::1:2.547: [udp sum ok] dhcp6 solicit (xid=87cb80 (elapsed-time 3041) (option-request SIP-servers-domain SIP-servers-address DNS-server DNS-search-list SNTP-servers NTP-server AFTR-Name opt_67 opt_94 opt_95 opt_96 opt_82) (client-ID hwaddr type 1 3c37862ad198) (reconfigure-accept) (Client-FQDN) (IA_NA IAID:1 T1:0 T2:0) (IA_PD IAID:1 T1:0 T2:0 (IA_PD-prefix ::/48 pltime:0 vltime:0))) Virkelig mærkeligt at ser ud til at være korrekt selv med default egentligt prøvede af manuelt med odhcp6c igår og næsten alle opsætninger sendte IA_NA IA_PD og IAID. Af opsummering af alle indlæg jeg har set IA_NA:1, IA_PD:1,IAID:1. Jeg tror ikke jeg burde efterligne alle OPTIONS med mindre jeg havde kviknet's router som bridge (jeg bruger egen R7800 direkte til NOKIA ONT terminal).
--
#13
CyberOpz
Ultra Supporter
19-11-2021 13:52

Rapporter til Admin
#12 - Jeg havde ikke alle de options på mit request. Fik IPv6 på klienterne alligevel. Fik lavet denne capturefil: https://mtsnonline-my.sharepoint.com[...] - Du skal specifikt se efter Neighbor Solicitation og Neighbor advertisement. Måske kan det hjælpe.
--
#14
lalandia
Ny på siden
19-11-2021 14:25

Rapporter til Admin
Tusind tak for hjælpen. Jeg ser kun ICMPv6 pakker i dumpet - mangler derfor DHCPv6 hvor options bliver sendt ved første syn.
--
#15
CyberOpz
Ultra Supporter
20-11-2021 08:49

Rapporter til Admin
#14 - Nåh ja. Mit problem bestod ikke i DHCPv6 pakkerne ikke blev leveret. Men at routeren modtog IPv6, dog uden at der kunne sendes trafik via IPv6 på routeren. Det kunne der godt via LAN klienterne. Det kom aldrig til at virke.
--
#16
CyberOpz
Ultra Supporter
23-11-2021 23:13

Rapporter til Admin
I linket fra #1, skriver Yoel (chefen i Kviknet), at en af brugerne skal skiftes til en Linux BNG i stedet for ZTE standard IPv6 relay agent.
--
#17
lalandia
Ny på siden
24-11-2021 18:29

Rapporter til Admin
#16 Ja gad vide om det er en mulighed der kunne hjælpe mig. Har jo ikke turdet skrive til supporten når de skriver der ingen support er så tænker jeg jo bare jeg må leve med det til jeg finder en løsning. Det kunne være rart hvis det bare virkede, eller ihvf ville svare til de gængse klienter når de sender de options der spørges efter. Har siden da kigget på OPNsense efter at have set denne tråd, ser ud som at være næste investering :) Kæft de er dyre de mini-pc'er.
--
#18
CyberOpz
Ultra Supporter
25-11-2021 11:37

Rapporter til Admin
#17 - min erfaring er at de er ret venlige i supporten og at de rent faktisk gør et forsøg på at hjælpe. Men spørg dem evt. efter Linux BNG. Jeg har ikke erfaring med det, men når Yoel anbefaler det, så kunne det tyde på at det løser problemerne. Hvis du er interesseret, så har jeg et DIY mini-itx setup baseret på Super Micro A2SDi-4C-HLN4F bundbræt https://www.supermicro.com[...] der samler støv og savner en ny ejer.
--
#19
Peter.
Monsterbruger
25-11-2021 13:30

Rapporter til Admin
Kører IPv6 her med kviknet på OpnSense uden problemer, med lign. config som den posted på V2, det virker fint nok. OPNsense kører på en VM, på en KVM host.
--
#20
lalandia
Ny på siden
26-11-2021 19:42

Rapporter til Admin
Ville ønske nogen vidste hvordan man fik det til at virke med Openwrt i første omgang, ellers må jeg jo skrive til supporten nu alt ser ud til at være korrekt fra dumpet. Har nemlig lige købt nye høretelefoner og kontorstol så er ret flad.
--

Opret svar til indlægget: Kviknet IPv6 ?

Grundet øget spam aktivitet fra udlandet, er det desværre ikke muligt for dig, at oprette svar som gæst.

Hvis du ønsker at deltage i debatten, skal du oprette en brugerprofil.

Opret bruger | Login
NYHEDSBREV
Afstemning